MT4 Old vs New - Old scripts and EA's not functioning as they used to - Page 13
Page 13 of 14 FirstFirst ... 391011121314 LastLast
Results 121 to 130 of 131

Thread: MT4 Old vs New - Old scripts and EA's not functioning as they used to

  1. #1
    Registered user
    Join Date
    Jul 2014
    Posts
    1
    Thumbs Up
    Received: 0
    Given: 0

    Post MT4 Old vs New - Old scripts and EA's not functioning as they used to

    I have Hline alert and Tline Alert and few other things that used to work and still does in past versions of MT4 from Roboforex, I had to find the experts folder to load my EA's etc into it same with the scripts and templates.

    Can I ask why is this ? Is tehre some setting that I am now not aware of or changes made that impact older code not working on the MT4 anymore.
    My close all script only closes the buy trades when it used to close EVERYTHING.

    Is it possible to run the previous versions of MT4 and stop it forcing you to update ? Where can I find the previous versions ?

    Apologies if this is on the wrong blog, wrong website, wrong area, duplicate of another post, in the wrong section ... or any other mistake I could have made, I aint perfect - y-alll

    Mike

    Not allowed!

  2. #121
    Trader
    Join Date
    Dec 2016
    Posts
    4,841
    Thumbs Up
    Received: 17
    Given: 2
    If you encounter issues with the use of old scripts of version then you should try the new version that is available for you to use in the market, mt4 trading platform is a good platform so such issues should not makes traders to discouraged at all of course that is not a big issue at all, when you find out that the old script of mt4 is not working perfectly then it is your decision to upgrade it and not to disregard mt4 trading platform as not working proper.

    Not allowed!

  3. #122
    Trader jamey's Avatar
    Join Date
    Aug 2015
    Posts
    813
    Thumbs Up
    Received: 7
    Given: 12
    It may be problem woith the old version ea in new version platform but it should not be problem because ea runs on mql language and both old and new version platform should support mql programmed ea. But if you have any error then it should may be some modify your ea.

    Not allowed!

  4. #123
    Trader
    Join Date
    May 2016
    Posts
    5,530
    Thumbs Up
    Received: 22
    Given: 4
    I don't really see that as an issue at all, when you can't work with the old script of the version then you should switch to the new version of the script. I do know that all programs can work perfectly if the trader in question have the experience of trading with programs perfectly. So we should have a good experience and potential skills of trading the market in all times.

    Not allowed!

  5. #124
    Trader
    Join Date
    Dec 2017
    Posts
    129
    Thumbs Up
    Received: 0
    Given: 0
    I've always had my skepticisms about expert advisors.
    Although I hope to develop mine someday but at the moment I don't just trust these EA's.
    A program or script might work for a short period, especially when the market is at ease and no pressure is on.
    But when price begins to dwindle frantically, these programs are unable to adapt.
    And I'm sorry for the accounts that run on these scripts cos the losses would be unbearable.
    My advice, focus, work hard, be consistent, you'd get there.
    We're far better than any script.

    Not allowed!

  6. #125
    Trader
    Join Date
    Jun 2017
    Posts
    9,294
    Thumbs Up
    Received: 28
    Given: 12
    If the old scripts are not working on newer versions of mt4 be rest assure that the script need an update too to work smoothly in your new meta trader platform, but I haven't experience any issue like this before, cause every time I upgrade my terminal to the newer version the script work just the same way it was before, but if you find your own script not working you need to update them as well.

    Not allowed!

  7. #126
    Trader
    Join Date
    Dec 2017
    Posts
    129
    Thumbs Up
    Received: 0
    Given: 0
    I really don't think old scripts become defunct when applied to the new trading platform.
    They use the same programming language so where does the disparity come in from.
    I would advice you check your installation procedure and verify that you did it right.

    Not allowed!

  8. #127
    Trader
    Join Date
    Aug 2013
    Posts
    11,566
    Thumbs Up
    Received: 69
    Given: 48
    the new meta trader may have new languages in his programming and so the old scripts may not work and so it may needs to be programmed again to work with the new versions of the meta trader, the trader needs to trade with the experts or scripts familiar with the news versions to be able to work well and make more and more money

    Not allowed!

  9. #128
    Trader jamey's Avatar
    Join Date
    Aug 2015
    Posts
    813
    Thumbs Up
    Received: 7
    Given: 12
    I really do not see any problem, when you can not work with older versions of the version, then your script should switch to a newer version. I know that all programs can work perfectly if the businessman has the experience of fully programmed with the query. So we always have a good experience of trading and potential skills in the market.

    Not allowed!

  10. #129
    Trader
    Join Date
    May 2019
    Posts
    55
    Thumbs Up
    Received: 0
    Given: 0
    luckily my programs can still work on the new mt4 only i have to reinstall it on my pc because it still uses windows xp and now it doesn't support the latest metatrader which must be installed on windows 7 and after windows on my pc already replaced with Windows 7 all scripts and EA all indicators can run smoothly again

    Not allowed!

  11. #130
    Trader
    Join Date
    Nov 2015
    Posts
    67
    Thumbs Up
    Received: 0
    Given: 0
    Trading indicator using is good for us. But, Trading time frame base trading signal provide by achieve a good profit from this market. and its true.
    The old versions used data write back, and multiple calls did not lead to script operation slowdown

    Not allowed!

Page 13 of 14 FirstFirst ... 391011121314 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •